Featured articles

AI

OpenAIがSignin with ChatGPT(OpenID Connectベース)を提供開始

(編集中:最終更新 2026-10-02 12:39 JST)OpenAIが9月29日のDevDay 2026でSign in with ChatGPT (SIWC) を正式発表しました。で、自分で手でチェックしたりして記事を書きたいところですが、ちょっと今時間が取れません。なので、ChatGPT自…

Read more

Archive

カテゴリー: OpenID

Events

Open Data in Finance @ London は6月15日!

FinTechの3本柱の1つとして注目されるAPIですが、特に欧州ではPayment Service Directive 2で銀行が2017年末までに金融API提供を義務付けられたことに伴い、とてもホットな話題になっています。日本ではまだまだブロックチェインの後塵を配していますが、まだまだリサーチ・プロジェクトと言っても良いブロックチェインに比べて、金融AP…

Events

Pre-IIW OpenID Workshop @ Mountainview (2015/10/26)

今回私はISOジャイプール会合に出ているので行かれなくてとても残念なのですが、以下のセミナーがマウンテンビューであります。 OpenID Foundation Workshop before Fall 2015 IIW Meeting Hosted by Symantec for the OpenID Foundation Monday, October 2…

identity

JSON Web Key (JWK) Thumbprint が、RFC 7638 として発行されました。

Mike Jones と私が共著者としてクレジットされている「JSON Web Key (JWK) Thumbprint」 が、[RFC 7638] として発行されました。 この規格はJSON Web Key (JWK)の安定的なハッシュ値を計算するための方法を規定しています。具体的には、JWKのどのフィールドをハッシュ値計算に使うか、これらフィールドの正規…

Events

OpenID Summit Tokyo 2015 発表募集開始

来る11月10日に、東京・飯田橋でOpenID Summit Tokyo 2015が開催されます。 これの発表募集(Call for Presentation)が開始されました[1]。 各発表は持ち時間20分(15分+質疑応答5分)で、みなさんよくご存知のTEDライクなプレゼンテーションが期待されています。 対象となる講演の主題は、 講演の内容は以下の領域に…

OAuth

MacOS XとiOSのXARA脆弱性について

今日(6月18日)午後、GigaZineで「iOSとOS XでiCloud・メール・ブラウザ保存のパスワードが盗まれる脆弱性が発覚、Appleは半年以上も黙殺」というセンセーショナルな記事が出ました。まぁ、Webメディアだからしょうがないかという感じではありますが、記事を読んだだけでは何のことやらさっぱりなので、読みましたよ、元の論文。 その論文は、これです…

identity

「番号」設計のあるべき姿 〜 年金番号漏洩事件によせて

年金番号漏洩事件では、「漏洩した番号は全て変更する」のだそうです。個人的には「あーあ」という感じでありんす。昨日の記事でも書いたとおり、適切に運用していれば、番号自体の漏洩は大したリスクではなく、一緒に漏れた住所氏名他が変えられない以上、年金番号だけ変えてもあまり意味が無いからです。 逆に、設計の古い年金番号は、変えるとなると、連動して変えなければいけないと…

identity

アメリカの不動産業界がWeb APIの認証にOpenID Connectを採用

Peter Williams氏の報告[1]によると、アメリカの不動産業界がWeb APIの認証にOpenID Connectを採用することを決定したようです。知らなかったんですが、不動産業界って、GDPベースでは米国最大のセクターなんですね。米国商務省経済分析局の 2014年ベースの統計[2]でGDPの13%を占めています。2番めのセクターが政府セクターで、…

OAuth

JWSとJWTがRFCになりました!

ずいぶん長くかかりましたが[1]、JSON Web Signature (JWS)とJSON Web Token (JWT) がようやく Standard Track の RFC[2]になりました。それぞれ、[RFC7515]と[RFC7519]です。 ご存じない方のために申し上げますと、JWSはJSONにデジタル署名するための規格です。XML署名のJSON…

identity

グーグル、マイクロソフト、ペイパル、野村総合研究所などの実装がOpenID Connect適合性試験に合格

(図1)OpenID Certified ロゴ 米OpenID® Foundationは現地時間22日、OpenID Connect実装適合性自己認証プログラムを発表しました。これは、OpenID Foundationが提供するオンライン・テストに実装が合格したことを、その証憑と合わせてOpenID Foundationに提出・宣言することによってOpenI…