When I happened to notice, courier-mta was spewing out a lot of errors. In fact, it was receiving mail, but apparently it wasn’t able to send any. The error was:
Address family not supported by protocol
Hmm, I thought it might be something related to IPv6, but it turned out that /etc/resolv.conf simply wasn’t written correctly. Specifically,
nameserver 127.0.0.1
Even though it had to be specified like that, for some crazy reason I had written localhost instead. orz
Related posts
Let’s Call Japan Post’s Digi-Ad API and Retrieve an “Address.” Is It Really OAuth?
Sorry for the long gap after I became unwell. In the previous article, I obtained a Japan Post Digital Address (Digi-Ad) and used it in Japan…

X (formerly Twitter) to Remove “Like” and “Repost” Counts from the Timeline
It appears that X (formerly Twitter) will remove the counts for “likes” and “reposts” from the timeline. As of March 8, tweets in the timeline show…

I Asked ChatGPT to Explain ID Tokens and Access Tokens in the Style of the King James Bible
People in the community have been having fun asking it to explain various things, and among them, Sarah Cecchetti, Head of Cognito at AWS, had it…
